智能涨跌停主图指标公式 通达信

来源:股票指标公式网 时间:2020-09-10 浏览量(

如何通过k线图更好的看出股票涨跌停,本文给大家介绍一个通达信智能涨跌停主图指标公式:
 
{涨停黄色,跌停白色,解决创业板,科创板20%,ST5%,8月23日以前的10%不影响,可转债不显示涨跌停}
{板块}
所属板块:=STRCAT(STRCAT(STRCAT('【行业】',HYBLOCK),STRCAT(' 【地域】',DYBLOCK)),STRCAT(STRCAT(' 【概念】',GNBLOCK),STRCAT(' 【风格】',FGBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0,0,0,所属板块),COLORRED;
赚钱轨道:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORRED;
XA_1:=MA(CLOSE,20);
DRAWBAND(赚钱轨道,RGB(155,50,50),XA_1,RGB(0,100,50));
IF(赚钱轨道<XA_1 OR CLOSE<赚钱轨道,赚钱轨道,DRAWNULL),COLORBLUE;
拉升线:IF(赚钱轨道>XA_1,XA_1,DRAWNULL),COLORMAGENTA;
下跌线:IF(赚钱轨道<=XA_1,XA_1,DRAWNULL),COLORLIBLUE;
M5:EMA(CLOSE,5),COLORWHITE;
DRAWTEXT(ISLASTBAR=1,M5,' 5日线'),LINETHICK2,COLORWHITE;
M10:EMA(CLOSE,10),COLORYELLOW;
DRAWTEXT(ISLASTBAR=1,M10,' 10日线'),LINETHICK2,COLORYELLOW;
M20:EMA(CLOSE,20),COLORRED;
DRAWTEXT(ISLASTBAR=1,M20,' 20日线'),LINETHICK2,COLORRED;
M60:EMA(CLOSE,60),COLORMAGENTA;
DRAWTEXT(ISLASTBAR=1,M60,' 60日线'),COLORMAGENTA;
M120:EMA(CLOSE,120),COLORCYAN,NODRAW;
{DRAWTEXT(ISLASTBAR=1,M120,' 120日线'),COLORCYAN;}
M250:EMA(CLOSE,250),COLORGREEN,NODRAW;
{DRAWTEXT(ISLASTBAR=1,M250,' 250日线'),COLORGREEN;}
DRAWICON(CROSS(C,M60),LOW*0.97,33);{穿60线,紫色狮子头}
多头:M5>REF(M5,1) AND M5>M10 AND M10>M20 AND C>M60 AND C>M120 AND C>M250,COLORRED,NODRAW;
DRAWICON(多头=1,M60*1.02,9);{多头}
压力:EMA(REF(HHV(C,20),1),3),LINETHICK2,COLORCC7733;
支撑:EMA(REF(LLV(C,20),1),3),LINETHICK2,COLORBROWN;
涨跌系数:=IF((INBLOCK('科创板') OR INBLOCK('创业板')),0.2,IF(INBLOCK('ST板块'),0.05,0.1));
STICKLINE((C>=ZTPRICE(REF(C,1),涨跌系数) AND C=H) OR (C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H AND DATE<=1200823) AND PERIOD=5 AND NOT(INBLOCK('可转债')),C,O,2,0),COLORYELLOW;
STICKLINE((C<=DTPRICE(REF(C,1),涨跌系数) AND C=L) OR (C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L AND DATE<=1200823) AND PERIOD=5 AND NOT(INBLOCK('可转债')),C,O,2,0),COLORWHITE;
STICKLINE((H>=ZTPRICE(REF(C,1),涨跌系数) AND C<H) OR (H>=ZTPRICE(REF(CLOSE,1),0.1) AND C<H AND DATE<=1200823) AND PERIOD=5 AND NOT(INBLOCK('可转债')),H,MAX(C,O),0.01,0),COLORYELLOW;{炸板——涨停后回落}
STICKLINE((L<=DTPRICE(REF(C,1),涨跌系数) AND C>L) OR (L<=DTPRICE(REF(CLOSE,1),0.1) AND C>L AND DATE<=1200823) AND PERIOD=5 AND NOT(INBLOCK('可转债')),L,MIN(C,O),0.01,0),COLORWHITE;{撬板——跌停后回升};

本站内容来源网络,仅提供给大家测试参考学习使用,不对内容做保证。股票风险大,大家炒股需谨慎!

标签:

相关推荐