怎么更改k线颜色?通达信创业板涨停变色主图指标公式源码

来源:股票指标公式网 时间:2020-09-06 浏览量(

怎么更改k线颜色?通达信创业板涨停变色主图指标公式源码
 
高开涨幅%:(REF(C,1)-O)/REF(C,1)*-100 NODRAW COLORMAGENTA;
DRAWKLINE(H,O,L,C);{重绘K线}
VER1:=IF(DATE<=1200823,1,0);
BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板') AND DATE>VER1,0.2 ,IF(INBLOCK('ST板块'),0.05,0.1)));
涨停:=C>=ZTPRICE(REF(C,1),BK) AND C=H;
跌停:=C<=DTPRICE(REF(C,1),BK) AND C=L;
STICKLINE((C=ZTPRICE(REF(C,1),BK) AND C=H),C,O,2.6,0),COLOR00FFFF;
STICKLINE((C=DTPRICE(REF(C,1),BK) AND C=L),C,O,2.6,0),COLOR80FF00;
RC1:=REF(C,1);
CS:=IF(C>=1,10000,100000);
C涨停10:=1.10*RC1-49/CS;
C涨停5 :=1.05*RC1-49/CS;
C跌停10:=0.90*RC1+51/CS;
C跌停5 :=0.95*RC1+51/CS;
大阳线:=C>O AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);
STICKLINE(涨停,O,C,2.6,0),COLORMAGENTA;
STICKLINE(跌停,O,C,2.6,0),COLORBLUE;
{涨停K线变色,科创板20%变色}
BK1:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1));
STICKLINE((C=ZTPRICE(REF(C,1),BK1) AND C=H),C,O,2.5,0),COLORMAGENTA;
STICKLINE((C=DTPRICE(REF(C,1),BK1) AND C=L),C,O,2.5,0),COLORGREEN;
STICKLINE((H=ZTPRICE(REF(C,1),BK1) AND C<H AND C<O),C,O,2.5,0),COLORGREEN;{收阴}
STICKLINE((H=ZTPRICE(REF(C,1),BK1) AND C<H AND C>O),C,O,2.5,0),COLORRED;{收阳};

本站内容来源网络,仅提供给大家测试参考学习使用,不对内容做保证。股票风险大,大家炒股需谨慎!

标签:

相关推荐