股票十剑合一指标 通达信十剑合一指标公式编写源码

来源:股票指标公式网 时间:2020-09-03 浏览量(

股票十剑合一指标 通达信十剑合一指标公式编写源码
 
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,30);
VAR4:=MA(CLOSE,60);
VARB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC:=INTPART(VARB*100)/100;
VARD:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE:=EMA(VARD,9);
VARF:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
VAR10:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
VAR11:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
VAR12:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
VAR13:=REF(VARE,1);
VAR14:=VARE;
VAR15:=VAR14-VAR13;
VAR16:=REF(VARD,1);
VAR17:=VARD;
VAR18:=VAR17-VAR16;
VAR19:=OPEN;
VAR1A:=CLOSE;
黑马剑: IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.8,0),LINETHICK3 , COLOR00FFFF;
STICKLINE(黑马剑,0,黑马剑*0.86,2,1),LINETHICK3 ,COLOR00FFFF;
DRAWICON(黑马剑>0,黑马剑,1);
MA1:=EMA(CLOSE,5);
MA2:=EMA(CLOSE,10);
MA3:=EMA(CLOSE,20);
MA4:=EMA(CLOSE,30);
三线粘合剑:CROSS(MA1,MA2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018,COLORFF00FF;
STICKLINE(三线粘合剑,0,三线粘合剑*0.96,2,1),COLORFF00FF;
DRAWICON(三线粘合剑>0,三线粘合剑,1);
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=HHV((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,200);
M1:=BIAS1=BIAS2 ;
M2:=V>MA(V,5) ;
M3:=REF(BIAS1,1)<REF(BIAS2,1) ;
追魂剑:IF(M1 AND M2 AND M3,0.60,0),COLORFFCCCC,LINETHICK2;
STICKLINE(追魂剑,0,追魂剑*0.56,2,1),COLORFFCCCC,LINETHICK2;
DRAWICON(追魂剑>0,追魂剑,1);
B1:=REF(OPEN,1);
B2:=REF(CLOSE,1);
B3:=IF(B2-B1>0,1,0);
A1:=CLOSE;
A2:=LOW;
A3:=(B2-LOW)/CLOSE;
A4:=IF(A3>=0.035,B3,0);
A5:=IF(CLOSE>=B2,A4,0);
追涨:=IF(CLOSE>=OPEN,A5,0);
追涨1:IF(追涨>0,1,0), STICK,COLORF00FF0,LINETHICK4;
DRAWICON(追涨1>0,1 ,1 );
VAR2A:=(EMA(CLOSE,26)-EMA(CLOSE,52))/MA(CLOSE,60)*100;
VAR3A:=EMA(VAR2A,18);
VAR4A:=VAR2A<-1;
VAR5A:=VAR4A AND CROSS(VAR2A,VAR3A);
追2:=VAR5A;
追涨2:IF(追2>0,0.8,0),STICK,COLORYELLOW,LINETHICK4 ;
DRAWICON(追涨2>0,0.85 ,1 );
X:=EMA(CLOSE,30)-EMA(CLOSE,17);
Y:=EMA(X,13);
短针2:=TROUGHBARS(3,5,1)<1 AND X<Y;
短针3:=CROSS(X,Y) AND TROUGHBARS(3,5,1)<1;
追涨3:IF(短针3>0,0.6,0), STICK,COLOR00FF00,LINETHICK4;
DRAWICON(追涨3>0,0.6 ,1 );
追涨4:IF(短针2>0,0.4,0),STICK,COLORF0F000,LINETHICK4;
DRAWICON(追涨4>0,0.5 ,1 );
排序1:IF(追涨1>0 OR 追涨2>0 OR 追涨3>0 OR 追涨4>0,0.2,0),STICK,LINETHICK4,COLORRED;
C1:=HHV(C,115);
C2:=LLV(C,115);
C3:=C1-C2;
C4:=MA((C-C2)/C3-0.5,14)*20;
HH:=REF(HHV(C,66),2);
BUY1:=CROSS(C,HH) AND (HHV(C,110)/LLV(C,110)-1)*100<45 AND C4<5.666;
SIGN1:=LLV(C4,35)<-8.9 AND CROSS(C4,-7.815) AND C4<-1.2;
抄底:1*FILTER(SIGN1,41),STICK,LINETHICK4,COLOR00EE00;
追涨0:1*FILTER(BUY1,41),STICK,LINETHICK4,COLORFF00FF;
VAR1M:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR2M:=(EMA(CLOSE, 6)-EMA(CLOSE, 12))*100;
猎庄:VAR2M<13 AND VAR1M>9,STICK,COLORFFFFFF,LINETHICK2;
YD:=(COUNT(C<REF(O,1),13)>=10 OR COUNT(C<REF(C,2),13)>=10) AND COUNT(H/L>1.048,13)>=7;
DTJJ:=DMA(C,V/MA(V,13)/13);
L1:=C/DTJJ<0.91;
回调买入: YD AND L1,COLORBLUE,LINETHICK2;
A11:=CLOSE/MA(CLOSE,40);
A22:=CLOSE/MA(CLOSE,60)*100<71;
代号魔鬼:CROSS(A11,A22),COLORFFB0B0;
VAR2G:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR3G:=(CLOSE-VAR2G)/VAR2G*100;
专抢反弹:(REF(VAR3G,1)<-40 AND VAR3G>REF(VAR3G,1) AND REF(VAR3G,1)<REF(VAR3G,2) AND VAR3G-REF(VAR3G,1)>2.5)*1,COLORRED;
标签:

相关推荐