至尊变色MACD指标公式源码 通达信指标公式

来源:股票指标公式网 时间:2020-08-25 浏览量(

至尊变色MACD指标公式源码 通达信指标公式

DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORGREEN;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORCBCBC0;
STICKLINE(MACD1>=0,0,0,50,1),COLORWHITE;
DIF:DIF1,COLOR33FF33;
DEA:DEA1,COLORYELLOW;
MACD:MACD1,NODRAW,COLORMAGENTA;
强:IF(DIF1>=DEA1,DIF1,DRAWNULL),COLORRED,LINETHICK2;
低位金叉:=CROSS(DIF1,DEA1) AND DIF1<-0.1;
STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIF1,DEA1),BARSLAST(DEA1>=0));
二次金叉:=CROSS(DIF1,DEA1) AND DEA1<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二次金叉,DEA1*0.9,1) ;
A1:=BARSLAST(REF(CROSS(DIF1,DEA1),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIF1>REF(DIF1,A1+1) AND CROSS(DIF1,DEA1);
底背:DRAWLINE(A1=0,DEA1,底背离,DEA1,0),COLORBLUE,LINETHICK2;
A2:=BARSLAST(REF(CROSS(DEA1,DIF1),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF1,A2+1)>DIF1 AND CROSS(DEA1,DIF1);
顶背:DRAWLINE(A2=0,DEA1,顶背离,DEA1,0),COLORFF00FF,LINETHICK2;
{周期放大开关:1为普通模式,0为放大模式}
周期放大:=1;
数显开关:=1;
倍数:=
IF(PERIOD=11,1,{年}
IF(PERIOD=10,4,{季}
IF(PERIOD=9,6, {多日}
IF(PERIOD=8,10,{多分钟}
IF(PERIOD=7,12,{月}
IF(PERIOD=6,5, {周}
IF(PERIOD=5,5, {日}
IF(PERIOD=4,4, {60F}
IF(PERIOD=3,8, {30F}
IF(PERIOD=2,4, {15F}
IF(PERIOD=1,6, {5F}
IF(PERIOD=0,5, {1F}
1))))))))))));
N1:=IF(周期放大,12,12*倍数);
N2:=IF(周期放大,26,26*倍数);
N3:=IF(周期放大,9,9*倍数);
DIFF:EMA(CLOSE,N1) - EMA(CLOSE,N2),COLORWHITE,NODRAW;
红柱面积:IF(MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),NODRAW,COLORRED;
绿柱面积:ABS(IF(MACD<0,SUM(MACD,BARSLAST(MACD>0)),0)),NODRAW,COLORLIGREEN;
MACD面积:=IF(MACD>0,红柱面积,绿柱面积),NODRAW,COLORFFFF00;
位置:=MAX(HHV(DIFF,100),ABS(LLV(DIFF,100)));
{数显开关:1为打开,0为关闭}
DRAWNUMBER(数显开关=1 AND LONGCROSS(DEA,DIFF,3),位置*0.8,REF(红柱面积,1)),COLORRED;
DRAWNUMBER(数显开关=1 AND LONGCROSS(DIFF,DEA,3),0-位置*0.5,REF(绿柱面积,1)),COLORGREEN;
NOTEXTLMH: DRAWNUMBER(数显开关=1 AND ISLASTBAR AND MACD>0,位置*0.8,红柱面积),COLORRED;
NOTEXTLML: DRAWNUMBER(数显开关=1 AND ISLASTBAR AND MACD<0,0-位置*0.5,绿柱面积),COLORGREEN;
标签:

相关推荐