通达信虚拟成交额指标公式源码 股市虚拟成交额指标公式

来源:股票指标公式网 时间:2020-08-22 浏览量(

通达信虚拟成交额指标公式源码 股市虚拟成交额指标公式
 
M1:=5;
M2:=10;
M3:=60;
M4:=36;
M5:=135;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VAMO:=IF((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),AMOUNT/100000000.0*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VAMO,0,-1,-1),COLOR00C0C0;
当天亿:AMOUNT/100000000.0,VOLSTICK;
五日亿:MA(当天亿,M1);
十日亿:MA(当天亿,M2);
成交额:=IF(DYNAINFO(10)>99999999,STRCAT(CON2STR(DYNAINFO(10)/100000000,2),'亿'),STRCAT(CON2STR(DYNAINFO(10)/10000,0),'万'));
DRAWTEXT_FIX(1,0.96,0.0,0,成交额),COLORGREEN;
X_3:=IF(CURRBARSCOUNT=1,AMOUNT/100000000.0/FROMOPEN/REF(AMOUNT/100000000.0,1)-1,AMOUNT/100000000.0/REF(AMOUNT/100000000.0,1)-1);
STICKLINE(X_3>=0.99,0,AMOUNT/100000000.0,2,0),COLORYELLOW;
STICKLINE(X_3>=0.99,0,AMOUNT/100000000.0,1.4,0),COLOR38B0DE;
STICKLINE(X_3>=0.99,0,AMOUNT/100000000.0,0.5,0),COLOR5959AB;
B1:=STRCAT(DYBLOCK,' ');
B2:=STRCAT(B1,STRCAT(HYBLOCK,' '));
B3:=STRCAT(B2,STRCAT(FGBLOCK,' '));
B4:=STRCAT(B3,STRCAT(GNBLOCK,' '));
DRAWTEXT_FIX(ISLASTBAR,0.10,0.01,0,STRCAT(B4,0)) ,COLORWHITE;
AMOW:=AMOUNT,VOLSTICK;
AMO1:=MA(AMOW,5);
AMO2:=MA(AMOW,35);
AMO3:=MA(AMOW,135)LINETHICK2;
倍量1:=AMOW>=REF(AMOW,1)*2;
天量1:=AMOW=HHV(AMOW,0);
量比:V/REF(MA(V,5),1),NODRAW ;
量王:天量1&&倍量1&&量比>3&&(BARSCOUNT(C)+1)>120,COLORMAGENTA;
DRAWTEXT(量王 AND 量王=1, 2,'量王');
DRAWICON(量王 AND 量王=1, 1,27);
标签:

相关推荐