通达信支撑压力线指标公式源码 通达信支撑压力线指标

来源:股票指标公式网 时间:2020-08-18 浏览量(

  通达信支撑压力线指标公式源码 通达信支撑压力线指标

  该指标能够 加上到随意自购淘宝主图中,做为輔助操盘的用处,全自动划线指标都是有未来函数,在意的不必下载!!!指标能够 全自动绘制最近和中后期支撑线和压力线,盘感会更好!

  指标使用方法:

  1.回踩支撑线不碎,能够 逢低干预;

  2.遇压力线缩量下跌,能够 逢高减磅;

  3.提升压力线,压力线就会变为支撑线;

  4.跌穿支撑线,支撑线就会变为压力线。

  通达信支撑压力线指标公式源码 通达信支撑压力线指标:
 
{虚拟涨停K}
KXZT:=IF(CURRBARSCOUNT=1 AND PERIOD=5 AND NOT(C>1500 OR DYNAINFO(7)=0) AND C>=O,REF(CLOSE,1)*1.1,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,KXZT,MAX(OPEN,CLOSE),-1,-1),COLOR00C0C0;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{虚拟跌停K}
KXDT:=IF(CURRBARSCOUNT=1 AND PERIOD=5 AND NOT(C>1500) AND C<O,REF(CLOSE,1)*0.9,DRAWNULL),NODRAW; 
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,KXDT,MIN(OPEN,CLOSE),-1,-1),COLORLIBLUE;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
 
 
{近期划线-紫色}
XA_1:=REF(HIGH,3)=HHV(HIGH,2*3+1);
XA_2:=FILTER(XA_1,3);
XA_3:=BACKSET(XA_2,3+1);
XA_4:=FILTER(XA_3,3);
XA_5:=REF(LOW,3)=LLV(LOW,2*3+1);
XA_6:=FILTER(XA_5,3);
XA_7:=BACKSET(XA_6,3+1);
XA_8:=FILTER(XA_7,3);
XA_9:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
XA_10:=(HIGH+LOW)/2;
XA_11:=XA_4 AND NOT(XA_8 AND XA_9>=XA_10) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
XA_12:=XA_8 AND NOT(XA_4 AND XA_9<XA_10);
XA_13:=XA_4 AND NOT(XA_8 AND XA_9>=XA_10);
XA_14:=REF(BARSLAST(XA_11),1)+1;
XA_15:=BACKSET(XA_11 AND COUNT(XA_12,XA_14)>0,LLVBARS(IF(XA_12,LOW,10000),XA_14));
XA_16:=XA_15>REF(XA_15,1);
XA_17:=BACKSET(XA_16,2);
XA_18:=XA_17>REF(XA_17,1);
XA_19:=XA_18 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
XA_20:=REF(BARSLAST(XA_19),1)+1;
XA_21:=BACKSET(XA_19 AND COUNT(XA_13,XA_20)>0,HHVBARS(IF(XA_13,HIGH,0),XA_20));
XA_22:=XA_21>REF(XA_21,1);
XA_23:=BACKSET(XA_22,2);
XA_24:=XA_23>REF(XA_23,1);
XA_25:=BACKSET(ISLASTBAR,MIN(BARSLAST(XA_24),BARSLAST(XA_18))+1);
XA_26:=XA_25>REF(XA_25,1);
DRAWLINE(XA_26,IF(XA_24,HIGH,LOW),ISLASTBAR,IF(BARSLAST(XA_24)>BARSLAST(XA_18),HIGH,LOW),0),DOTLINE,COLORWHITE;
XA_27:=HIGH<REF(HIGH,REF(BARSLAST(XA_24),1)+1);
XA_28:=REF(HIGH,REF(BARSLAST(XA_24),1)+1)>REF(HIGH,REF(BARSLAST(XA_24),1)+2+REF(BARSLAST(XA_24),REF(BARSLAST(XA_24),1)+2));
XA_29:=XA_27 AND XA_28 AND XA_24;
XA_30:=BACKSET(XA_29,REF(BARSLAST(XA_24),1)+2);
XA_31:=XA_30>REF(XA_30,1);
XA_32:=LOW>REF(LOW,REF(BARSLAST(XA_18),1)+1);
XA_33:=REF(LOW,REF(BARSLAST(XA_18),1)+1)<REF(LOW,REF(BARSLAST(XA_18),1)+2+REF(BARSLAST(XA_18),REF(BARSLAST(XA_18),1)+2));
XA_34:=XA_32 AND XA_33 AND XA_18;
XA_35:=BACKSET(XA_34,REF(BARSLAST(XA_18),1)+2);
XA_36:=XA_35>REF(XA_35,1);
XA_37:=XA_31 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
XA_38:=REF(BARSLAST(XA_37),1)+1;
XA_39:=BACKSET(XA_37 AND COUNT(XA_36,XA_38)>0,LLVBARS(IF(XA_36,LOW,POW(10,20)),XA_38));
XA_40:=XA_39>REF(XA_39,1);
XA_41:=BACKSET(XA_40,2);
XA_42:=XA_41>REF(XA_41,1);
XA_43:=XA_42 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
XA_44:=REF(BARSLAST(XA_43),1)+1;
XA_45:=BACKSET(XA_43 AND COUNT(XA_31,XA_44)>0,HHVBARS(IF(XA_31,HIGH,-POW(10,20)),XA_44));
XA_46:=XA_45>REF(XA_45,1);
XA_47:=BACKSET(XA_46,2);
XA_48:=XA_47>REF(XA_47,1);
XA_49:=BACKSET(ISLASTBAR,MIN(BARSLAST(XA_48),BARSLAST(XA_42))+1);
XA_50:=XA_49>REF(XA_49,1);
XA_51:=BACKSET(ISLASTBAR,BARSLAST(XA_18)+1);
XA_52:=XA_51>REF(XA_51,1);
XA_53:=BACKSET(XA_52,REF(BARSLAST(XA_18),1)+2);
XA_54:=XA_53>REF(XA_53,1);
DRAWLINE(XA_54,LOW,XA_52,LOW,1),COLORMAGENTA;
XA_55:=BACKSET(ISLASTBAR,BARSLAST(XA_24)+1);
XA_56:=XA_55>REF(XA_55,1);
XA_57:=BACKSET(XA_56,REF(BARSLAST(XA_24),1)+2);
XA_58:=XA_57>REF(XA_57,1);
DRAWLINE(XA_58,HIGH,XA_56,HIGH,1),COLORMAGENTA;
 
 
{中期划线-绿色}
N:=8;
AAB:=REF(H,10)=HHV(H,2*11);
QQHY:=BACKSET(AAB,10+1);
CCW:=FILTER(QQHY,10) AND H=HHV(H,11);
AAB1:=REF(L,10)=LLV(L,2*11);
QYY1:=BACKSET(AAB1,11);
CCD1:=FILTER(QYY1,10) AND L=LLV(L,11);
ZGD:=HHV(H,60);
ZGD2:=CONST(ZGD);
ZDD:=LLV(L,60);
ZDD2:=CONST(ZDD);
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
 KOH:=L>REF(H,1);
 KOL:=H<REF(L,1);
 HIF:=L>REF(H,BARSLAST(KOH)+1);
 NHIF:=L<=REF(H,BARSLAST(KOH)+1);
 LIF:=H<REF(L,BARSLAST(KOL)+1);
 NLIF:=H>=REF(L,BARSLAST(KOL)+1);
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
 RRRSV:=SMA(下档线,3,1);
 KKK:=SMA(RRRSV,3,1);
 DDDDD:=((3 * RRRSV) - (2 * KKK));
 JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
 RSV24:=SMA(JJ12,3,1);
 K24:=SMA(RSV24,3,1);
 D24:=((3 * RSV24) - (2 * K24));
压力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD)))),COLORFFFFFF;
底部:=LLV(HIGH,30),COLOR00FF00;
 AA:=REF(H,N)=HHV(H,2*N+1); 
 AA1:=REF(L,N)=LLV(L,2*N+1);
 QY:=BACKSET(AA,N+1); 
 QY1:=BACKSET(AA1,N+1);
 CC:=FILTER(QY,N) AND H=HHV(H,N+1); 
 CC1:=FILTER(QY1,N) AND L=LLV(L,N+1);
 DDD:=BARSLAST(CC); 
 DD1:=BARSLAST(CC1);
 GDTS:=IF(CC,CURRBARSCOUNT,0);
 DDTS:=IF(CC1,CURRBARSCOUNT,0);
 DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS); 
 DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
 GDCS1:=CONST(DINGBUTS); 
 DDCS1:=CONST(DDTS1);
 S13:=CONST(REF(HIGH,GDCS1-1)); 
 GDCS13:=S13;
 DDCS13:=CONST(REF(L,DDCS1-1));
 DINGBUTS1:=REF(DINGBUTS,DDD+1);
 DDTS2:=REF(DDTS1,DD1+1);
 GDCS2:=CONST(DINGBUTS1);
 DDCS2:=CONST(DDTS2);
今日阻力:=REF(明日阻力 , 1),NODRAW;
今日支撑:=REF(明日支撑 , 1),NODRAW;
压力位:=IF(ISLASTBAR,压力2,DRAWNULL),NODRAW;
底部位:=IF(ISLASTBAR,底部,DRAWNULL),NODRAW;
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) ,COLORGREEN,LINETHICK1;
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1),COLORGREEN,LINETHICK1;
 



支撑压力线指标

支撑压力线指标


 

标签:

相关推荐