通达信黑马短线涨停指标公式 通达信短线涨停黑马指标源码

来源:股票指标公式网 时间:2020-08-14 浏览量(


通达信黑马短线涨停指标公式 通达信短线涨停黑马指标源码
 
XA_1:=IF(NAMELIKE(22),0,1);
XA_2:=IF(NAMELIKE(23),0,1);
XA_3:=DYNAINFO(17)>0;
XA_4:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),0);
XA_5:=SUMBARS(VOL,CAPITAL);
XA_6:=IF(CLOSE>LLV(CLOSE,XA_5),1,0-1)*IF(XA_4>LLV(XA_4,XA_5),1,0-1);
XA_7:=COUNT(IF(XA_6=0-1,1,0)=1,8)>2;
XA_8:=(CLOSE-DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/SUM(AMOUNT,13)/AMOUNT/VOL/100/100))/DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/SUM(AMOUNT,13)/AMOUNT/VOL/100/100)*100<0-18;
XA_9:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE<0.009;
XA_10:=XA_7 AND XA_8 AND XA_9;
XA_11:=OPEN<EMA(CLOSE,5) AND CLOSE/OPEN>=1.105 AND VOL/CAPITAL>=0.019 AND VOL/CAPITAL<=0.2;
XA_12:=XA_11 AND COUNT(XA_11,5)=1;
XA_13:=MA(CLOSE,3)>REF(MA(CLOSE,3),1) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND VOL/240>REF(VOL,30)*1.2/240*1.5 AND CLOSE>LOW*1.059 AND CLOSE>REF(MA(CLOSE,3),1) AND REF(CLOSE,1) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,20)>REF(MA(CLOSE,20),1) AND MA(VOL,5)>REF(MA(VOL,5),1) AND MA(CLOSE,5)-MA(CLOSE,10)<=0.579;
XA_14:=FILTER(XA_13,5);
涨停黑马:XA_10 OR XA_11 AND XA_14 AND XA_1 AND XA_2 AND XA_3,STICK,COLORYELLOW;
STICKLINE(CLOSE>=OPEN,0,涨停黑马,2.8,0),COLORRED;
STICKLINE(CLOSE>=OPEN,0,涨停黑马,2,0),COLORYELLOW;
STICKLINE(CLOSE>=OPEN,0,涨停黑马,1.2,0),COLORMAGENTA;
DRAWTEXT(涨停黑马,0.9,24),COLORYELLOW;
DRAWTEXT(涨停黑马,0.7,25),COLORLIMAGENTA;
DRAWTEXT(涨停黑马,0.5,26),COLORYELLOW;
DRAWTEXT(涨停黑马,0.3,27),COLORMAGENTA;
标签:

相关推荐