[和正农牧股吧]军师和将军主图之副军师在此选股指标公式

来源:股票指标公式网 时间:2020-07-08 浏览量(

X:=70;
Y:=1;
股龄:=(BARSCOUNT(CLOSE));
A1:=COST(95);
A2:=COST(85);
A3:=COST(75);
A4:=COST(65);
A5:=COST(55);
A6:=COST(45);
A7:=COST(35);
A8:=COST(25);
A9:=COST(15);
A10:=COST(10);
A11:=COST(8);
A12:=COST(6);
A13:=COST(4);
A14:=COST(2);
B1:=MA(A1,X);
B2:=MA(A2,X);
B3:=MA(A3,X);
B4:=MA(A4,X);
B5:=MA(A5,X);
B6:=MA(A6,X);
B7:=MA(A7,X);
B8:=MA(A8,X);
B9:=MA(A9,X);
B10:=MA(A10,X);
B11:=MA(A11,X);
B12:=MA(A12,X);
B13:=MA(A13,X);
B14:=MA(A14,X);
DIS0:=(A1+A2+A3+A4+A5+A6)/6;
DIS00:=MA(DIS0,49);
向下:=IF(DIS00<REF(DIS00,Y),1,0);
一直向上:=IF(COUNT(向下,60)<30,1,0);
红色将军:=IF(B14>=REF(B14,Y)AND B13 >= REF(B13,Y) AND B12 >= REF(B12,Y) AND B11 >= REF(B11,Y) AND B10 >= REF(B10,Y) AND 一直向上,1,0);
绿色军师0:=IF((B1<=REF(B1,Y) OR B2<REF(B2,Y) OR B3<REF(B3,Y) OR B4<REF(B4,Y) OR B5<REF(B5,Y)) AND B14>=REF(B14,Y) AND B13>REF(B13,Y) AND (B12>REF(B12,Y) OR B11>REF(B11,Y))AND COUNT(红色将军,70)<35 AND C/LLV(C,170)<1.8,1,0);
绿色军师1:=IF(股龄>990 AND 绿色军师0 AND C/LLV(C,1000)<4.5,1,0);
绿色军师2:=IF(股龄>490 AND 绿色军师0 AND C/LLV(C,500)<2.5,1,绿色军师1);
绿色军师:=IF(股龄<490 AND 绿色军师0,1,绿色军师2);
副军师在此:IF(绿色军师 AND COUNT(绿色军师,50)<=1,1,0);